This incident is now resolved. Our engineering teams have resolved the core issue and the resulting backlog is fully processed.
Posted Jun 19, 2026 - 23:08 UTC
Update
We apologize for the continued search degradation in the us-east-1 region. Our engineering teams have resolved the core issue and are currently working around the clock to process the resulting data backlog. We expect the issue to be resolved by end of day 6/19/26. As our systems safely work through this queue, you will begin to see gradual, incremental improvements in search performance. We understand the impact this disruption has on your daily operations and appreciate your patience. Supporting your business continuity remains our top priority, and we are fully committed to delivering the reliable, enterprise-grade service and transparent communication that you count on from us.
Posted Jun 19, 2026 - 18:52 UTC
Update
The recovery efforts for search data processing are progressing smoothly. Our engineering and operations teams remain fully engaged, working diligently to safely clear the remaining data.
Posted Jun 19, 2026 - 04:18 UTC
Update
Search data processing is actively progressing. However, due to the volume of the backlog, we will not meet the previously shared recovery timeline. Our teams remain focused on processing the remaining data, and we will provide further updates as recovery continues.
Posted Jun 18, 2026 - 17:24 UTC
Update
Search data processing is progressing, and customer impact continues to decline. However, due to the volume of the backlog, we will not meet our previously shared recovery timeline. We are continuing to work through the remaining data and will provide further updates as recovery progresses.
Posted Jun 18, 2026 - 07:40 UTC
Update
We continue to process the search data backlog and are seeing good progress. System performance will gradually improve as we work toward full recovery.
Posted Jun 18, 2026 - 01:27 UTC
Update
Update - Processing of the search data backlog is ongoing. We have adjusted our estimate and are now approximately 17 hours from being fully caught up. While we do not have a hard timeline for full resolution, incremental improvements should continue to be visible to some customers throughout the afternoon and overnight.
Posted Jun 17, 2026 - 20:34 UTC
Update
We continue to monitor processing. Previous guidelines for estimated ETA remain intact.
Posted Jun 17, 2026 - 17:57 UTC
Identified
We are continuing our work to restore full search functionality in the us-east-1 region. The system is currently processing a backlog of data, and we estimate we are about 16 hours from being fully caught up. While we do not yet have a definitive timeline for complete resolution, some customers may begin to notice performance improvements throughout the day. Our team remains actively engaged.
Posted Jun 17, 2026 - 14:10 UTC
Update
We are still actively working on this issue. Our engineers continue their efforts to restore full search functionality in the us-east-1 region.
Posted Jun 17, 2026 - 10:27 UTC
Update
The degraded performance impacting search functionality in the us-east-1 region remains active. Our engineers are continuing their work to implement a resolution.
Posted Jun 17, 2026 - 07:06 UTC
Update
The degraded performance affecting search functionality in the us-east-1 region is ongoing. Our engineers are actively working to resolve the issue.
Posted Jun 17, 2026 - 02:58 UTC
Update
Our team is continuing to investigate the cause of the degraded search performance in the us-east-1 region.
Posted Jun 16, 2026 - 23:33 UTC
Update
We are continuing to investigate.
Posted Jun 16, 2026 - 20:17 UTC
Investigating
We are currently experiencing degraded performance with our search functionality in the us-east-1 region, resulting in delays. Our team is actively investigating the issue and working toward a resolution. We will provide an update when available.
Posted Jun 16, 2026 - 19:23 UTC
This incident affected: Search (N. Virginia us-east-1).