Identity Security Cloud is currently experiencing a service disruption

Incident Report for SailPoint

Resolved

The SailPoint team has mitigated the service disruption with ISC
Posted Sep 08, 2026 - 12:52 UTC

Investigating

SailPoint is investigating an issue with Identity Security Cloud (ISC) in the EU-West-2 region. Impacted customers may experience failures loading Certification pages and APIs, as well as delayed availability for certain application instances. We are working to address the service disruption and will provide an update upon resolution.
Posted Sep 08, 2026 - 12:08 UTC
This incident affected: Access Certification (London eu-west-2).